NUnit Tests Performance down on TC 3.1,sln2008 runner, NUnit 2.4

Before upgrading to 3.1 we use some of EAP's pre-3.0 version.
With that version we run VS2008 solutions using sln2005 runner and set required system variable for framework, and tests was on NUnit 2.4.x. It works almost fine - runner says about problems, but worked - with only minor problems like red lamp during the build.
So today I try to upgrade to 3.1 and find very interesting thing - with sln2005 runner practically nothing changed - but when I switched to sln2008 and set NUnit 2.4 as test framework in settings build became slower in dozens of times.
Logs not say anything helpful to me.
May be it's the same problems as in http://jetbrains.net/tracker/_htmlTemplate/Issue?issue=25-4617

5 comments

I can confirm that we saw similar results. Previously a test ran in under 3 seconds under NUnit 2.2, but attempting to use 2.4 that time jumped to 2 minutes and 45 seconds.

0

Pavel:

Have you tried the "workaround" described in that bug report?

A new version of NUnit (2.4.7) has been released that might address the issues as some performance issues - including a race condition - have been addressed. Does anyone know if TeamCity needs modification before it can support 2.4.7?

0

Robert,
Not yet, as far as I understand this workaround is just revert to 2.4.1 - because I have already updated some used NUnit extensions to 2.4.6 it's a little idly for me. I dissect my projects by it's purpose and revert slowest parts to 2.2 and this satisfy my needs.
Thank you for info about 2.4.7, I voted for http://jetbrains.net/tracker/issue/TW-4885 and wait while JetBrains update launcher to 2.4.7.

Edited by: Pavel Samokha on Apr 10, 2008 11:02 PM

0

Hello,
Could you please have a look to http://www.jetbrains.net/tracker/issue/TW-4885.
There was added the patch for NUnit 2.4.7 support.

Could you please attach some performance comparisons, i.e. Tests on TC
from 2.4.7 and 2.4.6 and the same from NUnit-console.exe.

Thanks!

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Robert,

Not yet, as far as I understand this workaround is just revert to
2.4.1 - because I always update some used NUnit extensions to 2.4.6
it's a little idly for me. I dissect my projects by it's purpose and
revert slowest parts to 2.2 and this satisfy my needs.

Thank you for info about 2.4.7, I voted for
http://jetbrains.net/tracker/issue/TW-4885 and wait while JetBrains
update launcher to 2.4.7.



0

I migrate to 2.4.7 at last - it solves problems - thanks.

0

Please sign in to leave a comment.