Problem with 2.1 (4244) - svn: can't find a temporary directory

After upgrading from 2.0 to 2.1 (4244) projects stopped working, telling problems with
temporary directory. With 2.0 under the same environment it worked well.

We run TC under non-privileged account under Solaris 10, but this user has full r/w access
to common temp folders: /tmp , /var/tmp as well to own temp folders: ~/tmp , ~/temp

I suppose something changed in svnkit library, do we need to create an another temp folder, if so, which one ?

Thanks,
Dmitri

svn: svn://svnserver.intranet.alee.com/AleeSoftware/AleeArchive3
svn: Can't find a temporary directory
jetbrains.buildServer.vcs.VcsException: org.tmatesoft.svn.core.SVNException: svn: Can't find a temporary directory
at jetbrains.buildServer.buildTriggers.vcs.svn.SvnSupport.collectBuildChanges(SvnSupport.java:52)
at jetbrains.buildServer.buildTriggers.vcs.VcsChangesLoader.loadChanges(VcsChangesLoader.java:34)
at jetbrains.buildServer.serverSide.impl.ProjectImpl.loadChanges(ProjectImpl.java:49)
at jetbrains.buildServer.serverSide.impl.ProjectImpl.checkForModifications(ProjectImpl.java:158)

...

2 comments

Hi,

Please make sure that TeamCity/temp directory exists and writable.

Kind regards,
KIR

0

sorry for looong delay, but I got participated in a card accident and spent last month of 07 and beginning of 08 in a hospital %|

For sure, the question is solved ;) Thanks everyone !

0

Please sign in to leave a comment.