Build is failed but the result is success.

Hi team,

Teamcity are getting misleading information.

We have created a project with Build runner: maven2.

Build is failed but the build result is success.

Important messages | All messages
: BUILD ERROR
: -


: Error assembling WAR: Deployment descriptor: C:\TeamCity\buildAgentJava\work\a052aee9c177edc4\ocs-portal-addons-site\target\ocs-portal-addons-site-1.0\WEB-INF\web.xml does not exist.
:


The same issue we have with command line script.

Please advise !

Thank you,
Konstantin.

3 comments

Hello Konstantin,

You must be using Maven 2.0.7. This is a known problem in that release.
Please consider migrating to 2.0.8 or 2.0.9.

In case it's not possible you can patch mvn.bat yourself

The fragment at line 148 of mvn.bat


:error
set ERROR_CODE=1


should be replaced with


:error
if "%OS%"=="Windows_NT" @endlocal
set ERROR_CODE=1


Hope this helps

Hi team,

Teamcity are getting misleading information.

We have created a project with Build runner: maven2.

Build is failed but the build result is success.

Important messages | All messages

: BUILD ERROR

:
----------------------------------------------------------------------
--

: Error assembling WAR: Deployment descriptor:
C:\TeamCity\buildAgentJava\work\a052aee9c177edc4\ocs-portal-addons-sit
e\target\ocs-portal-addons-site-1.0\WEB-INF\web.xml does not exist.

:

The same issue we have with command line script.

Please advise !

Thank you,
Konstantin.

--
Sergey Anchipolevsky
Software Developer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


0

Hi Sergey,

It's working ! Thank you.
Appreciate.

Konstantin.

Edited by: contracosta on Jun 19, 2008 12:44 PM

0

Please sign in to leave a comment.