Undefined path variables

In order to be able to share our IML files, we've defined a M2 path variable in IDEA. It points to the local library repository.
TeamCity seems to have a problem with that:

java.lang.RuntimeException: There are undefined path variables in project configuration files.
: In order for the project to load all path variables must be defined.: M2

I have set the M2 variable in the BuildAgent's machine environment variable. I've add the path variable in the runner configuration itself, as well as in the system properties, I always get the error.

What can I do? Where am I suppose to set this variable?

5 comments
Comment actions Permalink

Hello,

Which build runner do you use? What settings did you specify?
Please read some help at http://www.jetbrains.net/confluence/display/TCD3/Ipr (or http://www.jetbrains.net/confluence/display/TCD3/Inspections)

Regards,
KIR

0
Comment actions Permalink

We use the Maven2 build runner, which work fine, and the Inspection Runner (with project file type Maven2) which fails.

Our M2 variable has been replaced in IDEA's 7860 by a MAVEN_REPOSITORY variable that is now included in project module.

The problem we have is the following:

Opening project...[ 5366] ERROR - ction.ex.InspectionApplication -
: java.lang.RuntimeException: There are undefined path variables in project configuration files.
: In order for the project to load all path variables must be defined.: MAVEN_REPOSITORY

I can define the MAVEN_REPOSITORY variable in the Environment Variables section of the build configuration, it doesn't make a difference.

-nodje

0
Comment actions Permalink

Nodje,

In fact, you should be able to specify MAVEN_REPOSITORY on the Inspection Runner screen (step 2).
If this variable is not visible on this screen, try setting system property path.macro.MAVEN_REPOSITORY in the build.

Hope this helps,
KIR

0
Comment actions Permalink

Kir, I can't figure out which screen you mean:
Step 2 is Version control settings for me.

Anyway, setting path.macro.MAVEN_REPOSITORY in system properties in the secion 6 Properties and environment variables worked!

thanks

0
Comment actions Permalink

Hello,

Sorry, I meant step 3 - build runner settings.

Anyway, glad that your problem is solved with setting system property.

Regards,
KIR

0

Please sign in to leave a comment.