TeamCity not getting all the files from source control (VSS)

Hi,

I'm just setting up a demo of Teamcity to present to my team. However, I have an issue when building my project in TeamCity.

I'm using SourceSafe 2005 as the version control system, and I've set the root to /$, which should get all files. However, at build time TeamCity is complaining that some .csproj files are missing (using a sln2005 build runner), I know these files are in SourceSafe, however in the worker folder that TeamCity creates the files are missing!

There are other csproj files in the worker folder, it just seems weird that only certain ones are missing. Is there anything I'm doing wrong here, or is there a bug in TeamCity? When I was investigating the tool on my home PC I used the same config and that worked perfectly so I'm not sure what I'm missing here.

Any help would be much appriciated.

Edited by: Yegor Yarko (JetBrains) on Jun 23, 2008 3:14 PM

7 comments

What is the version of VSS at your home/office? Actually here I need to know what is the version of ssapi.dll that is registered in the system for Source.Safe automation object.

What the version of TeamCity is used?

Could you please describe the history of changes of that missed files.

0

Hi,

We are currently using SourceSafe 2005.

The version of ssapi.dll in the SourceSafe directory is 8.0.50727.42

The actual history of the files doesn't seem unusual, the files in question did appear to be checked out when I attempted my 1st build - I'm not sure if this is relevant, though I've undone the checkout on those files and that hasn't changed anything.

All that has happend to these files in question (all csproj) files is that we've added additional files to the project.

0

Please have a look to http://www.jetbrains.net/tracker/issue/TW-5118. Watch/Vote for it. I have posted several patches there. Does that helps you?

Frankly speaking, TeamCity vss integration does not explicitly depend on Checkout status of the items.

0

Hi,

I didn't think that the checkout status would be a factor, but that was the only difference with the missing files at the time of 1st build from what I could see.

I'll checkout the patches and I'll update this thread with the outcome.

0

What VSS mode is used? Lock-Edit-Commit(Only one user is allowed to checkout an item) or Edit-Merge-Commit?

What is the version of VSS?

Looking forward to hear from you!

0

Hi,

I've just tried installing the patch files. The file it mentioned in the support panel you pointed me at did not exist in the C:\TeamCity\webapps\ROOT\WEB-INF\classes\bin folder originally, just the TFS-native.exe existed.

I stopped TeamCity copied the files and started TeamCity (assuming I don't need to do any other changes on the server). I did notice it is only missing 1 file now instead of the 3 csproj files it was originally missing.

I'm using VSS 2005 and we use the Lock-Edit-Commit mode at the moment.

0

Could you please attach logs as was described in the issue. I need path to that project file.

Thanks!

0

Please sign in to leave a comment.