Building a BizTalk Project

Hi, I'd welcome some help with getting a BizTalk solution to build under TeamCity.

BizTalk is installed along side Visual Studio 2005 on the build machine. My solution wil open and build without issue. When I setup a sln2005 runner and attempt a build, I get

D:\Build\Core\Project.Schemas\Project.Schemas.btproj(1, 1): error MSB4075: The project file must be opened in the Visual Studio IDE and converted to the latest version before it can be built by MSBuild.

I guess this isn't using devenv.exe to build ?

Regards, Jason

5 comments

Wow.

Great community support. Thank god I didn't pay for this.

Back to cruise control I guess. Sigh.

Edited by: Jason Hyland on Jul 5, 2008 11:00 PM

0

Jason Hyland wrote:

Hi, I'd welcome some help with getting a BizTalk solution to build under TeamCity.

BizTalk is installed along side Visual Studio 2005 on the build machine. My solution wil open and build without issue. When I setup a sln2005 runner and attempt a build, I get

D:\Build\Core\Project.Schemas\Project.Schemas.btproj(1, 1): error MSB4075: The project file must be opened in the Visual Studio IDE and converted to the latest version before it can be built by MSBuild.

I guess this isn't using devenv.exe to build ?

Regards, Jason


Right. MSBuild is used to build solution files.

--
Alexey Gopachenko
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Jason Hyland wrote:

Wow.

Great community support. Thank god I didn't pay for this.

Back to cruise control I guess. Sigh.

Edited by: Jason Hyland on Jul 5, 2008 11:00 PM


Commercial user may demand an answer from our commercial support.
Community in any case provides its support accordingly to its own good
will and available resources.

--
Alexey Gopachenko
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

sln2005 runner is built on top of msbuild runner. According to the issue you got, BizTalk does not support msbuild thus the only way is to install VS 2005 on each build agent.

To stack the build, you have to use devenv.exe. Path to vs would be set to $(VS2005_Path) property.

I have added an issue for that problem in out tracker. Please have a look/watch/vote for it at http://jetbrains.net/tracker/issue/TW-5385

Thanks!

0

Please sign in to leave a comment.