Problems when using schedule trigger

The exact time trigger feature is very helpful to my team, so i just tried it. I used the simplest setting. No VCS, a helloworld java project.

I set up the time trigger in Build Configuration Home->4 Build Triggering->Schedule->Add time trigger->Trigger build: advanced(cron expression) as just two minutes later than current time. At the trigger time, the build agent started to work. But it couldn't stop! It kept running and rebuilt the project again and again even every build finished successfully. Does anybody know how to fix this problem? Thanks very much!

Edited by: Wei Hu on Jul 4, 2008 1:12 AM

4 comments
Comment actions Permalink

I am guessing. Try this.

General settings:
1. Setup "Limit the number of simultaneously running builds (0 - unlimited)" to value 1

Build triggering
2. Switch off check box for "Enable triggering when files are checked into VCS"

Runner:
3. How you build application? Ant, Maven, Command line? Check your build script.

0
Comment actions Permalink

contracosta, thanks for your reply.

I use Maven2 as the build runner. I created a simple project by "mvn archetype:create ...", and then in Build Runner, my goal is simply "install". That's it! I didn't set up a VCS cuz i think TeamCity can run without communicating with VCS, right?

I tried your suggestions, but still doesn't work. Any more thoughts?

0
Comment actions Permalink

A tracker issue has been filled: http://jetbrains.net/tracker/issue/TW-5381
Please watch it for further discussion.

0
Comment actions Permalink

Update from Wei:
I just got a reply from a developer. He told me to try to set "year" as "*" but not an exact number. This works.

0

Please sign in to leave a comment.