Problem with 3.1 detecting SVN updates

I am going through the process of switching over our CI environment from some home grown stuff to Team City. We wanted to get set up with 3.1 because we need the 2.4 nUnit support. But I am having an issue that I hope someone can help me with.

I am not getting automatic detection of commits to subversion. I think I have everything set up correctly. If I run the project by hand, everything works perfectly. It will not run automatically after a commit though. I looked in the teamcity-server.log and I have a lot of messages like.

INFO - jetbrains.buildServer.SERVER - pack 'C:\Program Files\TeamCity\webapps\ROOT\js\prototype.js'net.sf.packtag.strategy.PackException: Could not pack resource
INFO - jetbrains.buildServer.VCS - Collecting changes for IMISManager; from version 2008/02/29 21:24:17 -0600; root=svn-config-directory=C:\Windows\system32\config\systemprofile\AppData\Roaming\Subversion

In addition the "from version " string is looking at something from Feb 29th. There have been several commits on Mar 1 and 2. Is this just the last version that TeamCity is tracking?

I would assume the presence of the message every minute or so means that it is contacting the svn server to check?

Any help would be greatly appreciated.

3 comments

Hi Dan,

Please check that:
1. Test connection buttons works OK on the Svn configuration UI
2. You've enabled setting "Enable triggering when files are checked into VCS" in Build Triggering section
3. Svn server and TeamCity have synchronized time

If all this is correct, build triggering by commits should work fine.
Regards,
KIR

0

That was it. The times were the same (I had checked that), but the timezone was off on one of the servers. Thanks for your help.

0

Apparently got ito the same situation - date shifter one-hour forward onour svnserver after administrator mistake while performing a maintenance. Unfortunately, this was detected only when there were several commits into SVN and people noticed, that TeamCity stopped making a builds.

The time was revetred back, so now it is the same as on TeamCity and Agent servers (as well as TZ), however, TeamCity performs starnge:

The HEAD build is 7817 , last build, detected and performed by an TeamCity was 7810. For now, when time is the same on all servers, TeamCity sleeps. If I make a commit into SVN (a commit obtains a 7818 revision) - TeamCity detectects one change and builds it - revision 7811 and so on. I commit next file - head revision becomes 7819, TeamCity detects and builds 7812...

It there any trick to reset TeamCity timestamp counter or so, in order to let it pickup and build all missed revisions ?

Thanks,
Dmitri

0

Please sign in to leave a comment.