Access for user 'SYSTEM' has not been enabled by 'p4 protect'.

During a project, I set up two build agents(one default agent on the server machine, one additional agent on another machine ), and use Perfoce as VCS system.
The username and password are the same on two agents.
I try to get the changelist of the checked out codes.
However, on the default agent , I got the message "Access for user 'SYSTEM' has not been enabled by 'p4 protect'.", while on the additional agent, the correct changelist can be returned, such as "8819".

Wondering why and how to solve this problem. Thanks.

2 comments

Probably your agent is running as service under the SYSTEM account. Try to specify different user account for agent service.

--
Pavel Sher

0

You are right! I changed the user account of the agent service, and now the error message does not occur.
Thanks a lot for your help.

0

Please sign in to leave a comment.