Labeling a build problem, no tags are created

Hello Everyone,

Had a question i was wondering if any one can tell me why isnot this working?

First this is my svn structure

NET
-Web
--trunks
-


Project.Web
-


Project.Library
-


Project.Tests
-


TeamCity.build (Nant script file )
--branches
--tags
-


build-0.0.1
-


build-0.0.2
.
.
.

when i try to create a tag using TeamCity Labeling setting, no tags are created in svn here are my settings udern VCS Root

-SVN Connection Settings
--URL: http://server1:81/svn/NET/Web/trunks

-Labeling settings (upon successful build i want to create a tag of Project.Web in svn)
--Labeling rules: /svn/NET/Web/trunks/Project.Web=>/svn/NET/Web/tags

this doesn't produce any errors and it just dosnot work however if i change the settings to

-SVN Connection Settings
--URL: http://server1:81/svn/NET/Web/

-Labeling settings
--Labeling rules: trunks/Project.Web=>tags

then this works, but the problem with this is, for every build Teamcity needs to check out trunks, branches and tags just to be able to compile the contents under trunk i am really trying to avoid that

Any help is appreciated I am using TeamCity Version 3.1.2 (build 6881)

thanks in advance

Amir

1 comment

Amir,

The labeling errors, if any, should be visible on the Changes tab of a build in the "VCS revisions and labels" section.

Please note that the absolute paths in the labeling rules should start from the repository root. So if "svn" directory is not actually present in your repository, you should probably try
/NET/Web/trunks/Project.Web=>/NET/Web/tags
rule.

If you decide to stick with "http://server1:81/svn/NET/Web/" VCS URL, you can limit what directories are checked out by specifying , like
-:.
+:trunks

Hope, this helps.

--
Best regards,

Yegor Yarko
Project Manager
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.