Ant Logging

When running a build through TC using the ant runner, the ant task property taskName is ignored. For example, when I run my build from the command line, I see something like this (as expected):
\[-BRA-0-] Writing final index.
\[-BRA-0-] Writing level 0 containing 1 sub-indexes.
\[-BRA-0-] Writing level 1 containing 382 sub-indexes.
\[-BRA-0-] Writing level 2 containing 7677 sub-indexes.
\[-BRA-0-] Finished creating street browse index file.
\[-BRA-0-] Creating alternate street search index files.
\[-BRA-0-] Alternate street search index files created.
\[-BRA-0-] Creating alternate street browse index files.
\[-BRA-0-] Alternate street browse index files created.
\[-BRA-0-] Finished creating street index files.

However, when running the build through TC, the log looks like this:
\[08:07:43]: \[java] Writing final index.
\[08:07:43]: \[java] Writing level 0 containing 1 sub-indexes.
\[08:07:43]: \[java] Writing level 1 containing 382 sub-indexes.
\[08:07:43]: \[java] Writing level 2 containing 7677 sub-indexes.
\[08:07:44]: \[java] Finished creating street browse index file.
\[08:07:44]: \[java] Creating alternate street search index files.
\[08:07:44]: \[java] Alternate street search index files created.
\[08:07:44]: \[java] Creating alternate street browse index files.
\[08:07:44]: \[java] Alternate street browse index files created.
\[08:07:44]: \[java] Finished creating street index files.

These logger lines are generated by running a ]]> task with the property taskName="-BRA-0-"

This logging is extremely helpful to us as many tasks are running in parallel and the taskname is the best way to tell which output belongs to which thread. Any ideas on how I can get the behavior I intended?

Thanks,
Ray

Edited by: Ray Navarette on Sep 16, 2008 4:26 PM

2 comments
Comment actions Permalink

Please submit a bug report to our tracker.

--
Pavel Sher

0
Comment actions Permalink

FYI: Tracker is down (using this URL: http://www.jetbrains.net/tracker/workspace/TW)

I'll try again later I guess.

-



EDIT: Looks like your link from the main website is wrong. If you go to this URL (http://www.jetbrains.com/devnet/index.html) and click the link to the tracker, an error message appears. Removing "www." from the clicked-on URL resolves to the proper place.

Edited by: Ray Navarette on Sep 16, 2008 7:10 PM

0

Please sign in to leave a comment.