how to have my "make" execute in "working directory"

Experts,

I configed TeamCity's "Build Runner" with "Command Line" mode. And set working directory to /home/myproject. My makefile lays right under /home/myproject, which uses $(PWD) to get project root.

But when I have the build triggered, I found the make was executed always under buildAgent's home directory, on my platform is "/buildAgent". That makes my $(PWD) contains /buildAgent instead of /home/myproject, which makes the build failed.

How could I fix this issue?

Thanks,

4 comments
Comment actions Permalink

It looks like a bug. What version of TeamCity do you use?

--
Pavel Sher

0
Comment actions Permalink

I am using "3.1.2 build 6881".

0
Comment actions Permalink

Please submit an issue to our tracker: http://jetbrains.net/tracker/workspace/TW with screenshot of your settings attached.

--
Pavel Sher

0
Comment actions Permalink

Pls see TW-5780

0

Please sign in to leave a comment.