Looks like bug while downloading folder-artifact

Greetings!

Thanks to Pavel Sher, he explained me how to get whole directory structure published as artifact.
But now I seem to have some other problem when I try to download this artifact :(

I've attached screenshots.
Help me please....

More details follow - in Firefox I don't see 'save' dialog menu item when I click on published artifact-folder.
It's so unconvenient :(. I have to download artifact file by file? Nooooooooooooooooooooooo ....

Edited by: Roger Taylor on Oct 10, 2008 9:17 AM



Attachment(s):
Is_It_Team_City_Bug.rar
3 comments
Comment actions Permalink

Can you publish an archive instead of plain files? There is an issue in our tracker http://jetbrains.net/tracker/issue/TW-220 to provide single link to download artifacts as one single file but it is not resolved yet. At the moment the only workaround is to prepare archive before publishing to TeamCity.

--
Pavel Sher

0
Comment actions Permalink

>Can you publish an archive instead of plain files? There is an issue in our tracker http://jetbrains.net/tracker/issue/TW-220 to provide single link to download >artifacts as one single file but it is not resolved yet. At the moment the only workaround is to prepare archive before publishing to TeamCity.
Thanks - I voted for this feature. How to compress artifact? Scripts? I do not use scripts - I use plain sln 2005 builder. Could u please gimme example of how-to compress artifact.

0
Comment actions Permalink

Please consider using some achiever or archive task from your buildscript.

For that you will have to wrap your solution .sln file with msbuild .proj file.
Call your solution from MSBuild project by using ]]> task
Than call process or task to zip output.

Please have a look to that blog post describing how to zip solution output:
http://weblogs.asp.net/pwelter34/archive/2005/12/05/432384.aspx

Thanks!

0

Please sign in to leave a comment.