Exception occured while patch applying:null

TeamCity: Version 3.1.2 EAP (build 6874)

I'm not sure what I changed, but all of a sudden my builds fail on source checkout with the error message "Error while applying patch: null".

Here is the output from the agent log:

INFO - jetbrains.buildServer.AGENT - Getting sources...
INFO - jetbrains.buildServer.AGENT - Requesting patch from server, cleanPatch=true
INFO - jetbrains.buildServer.AGENT - Copying patch to temp file...
WARN - jetbrains.buildServer.AGENT - Exception occured while patch applying:null
java.lang.NullPointerException
at jetbrains.buildServer.vcs.patches.LowLevelPatcher.applyPatch(LowLevelPatcher.java:62)
at jetbrains.buildServer.vcs.patches.AbstractPatcher.applyPatch(AbstractPatcher.java:56)
at jetbrains.buildServer.agent.impl.patch.ApplyPatch.execute(ApplyPatch.java:20)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.applyPatch(GetProjectSources.java:231)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.checkPatchInFileIsCompleted(GetProjectSources.java:374)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.copyPatchToTempFile(GetProjectSources.java:470)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.loadAndApplyPatch(GetProjectSources.java:188)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.access$300(GetProjectSources.java:23)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources$3.execute(GetProjectSources.java:337)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.executePatchProcess(GetProjectSources.java:132)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.applyPatch(GetProjectSources.java:335)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.execute(GetProjectSources.java:94)
at jetbrains.buildServer.agent.impl.BuildAgentImpl$BuildRunAction.run(BuildAgentImpl.java:1020)
at java.lang.Thread.run(Thread.java:595)

I'm not sure what to fix where. Here's what I've done:

1) Manually gone to source folder and deleted all files to get a "clean" source from subversion
2) Restarted Windows
3) Enabled logging

...I haven't done much because usually TeamCity just works :)

What shall I do to help you help me?

-Nick

Edited by: Nick DeVore on Nov 3, 2008 7:32 AM

3 comments
Comment actions Permalink

Please take a look at server log for the same time, are there any exceptions?

--
Pavel Sher

0
Comment actions Permalink

There were no exceptions, just INFO messages. See below:

INFO - tbrains.buildServer.ACTIVITIES - Configuration added to queue; name=SMART :: Build SMART Web; requestor=Nick DeVore
INFO - tbrains.buildServer.ACTIVITIES - Build started; name=SMART :: Build SMART Web, personal=false, buildId=382
INFO - tbrains.buildServer.ACTIVITIES - Configuration removed from queue; name=SMART :: Build SMART Web, requestor=Nick DeVore, comment=null, user=null
INFO - jetbrains.buildServer.SERVER - Running build saved to DB: 382 SMART :: Build SMART Web on agent pandora triggered by Nick DeVore
INFO - tbrains.buildServer.ACTIVITIES - Finishing build 382, name: Build SMART Web, personal: false, failed: true, interrupted: false, cancelled: null
INFO - serverSide.impl.DBBuildHistory - Start creating history entry for SMART :: Build SMART Web 382, date: 1225492015000
INFO - serverSide.impl.DBBuildHistory - End creating history entry for SMART :: Build SMART Web 382
INFO - jetbrains.buildServer.SERVER - Finished 382
INFO - ication.email.EMailNotificator - Email message with subject 'Build SMART::Build SMART Web #1.0.2.220 failed ' sent to

0
Comment actions Permalink

I just switched from "VCS Checkout Mode: Automatically on Server" to Automatically on Agent and then the build worked. That was the only thing I changed. I'm glad it worked, but anyone have any ideas in case this happens again?

0

Please sign in to leave a comment.