Registering assembly for COM interop

Hi,

I have a build configuration that runs MSBuild, as part of its nant script, on a solution that includes a com visible assembly.
When I run that build configuration, MSBuild tries to register that assembly for COM interop, and then the build configuration hangs until I stop it manually.
If I run MSBuild with the same parameters from a plain nant script it succeds.
The build agent service for that build configuration runs under the Local System user.

How can I tell why the build is hanging?
It looks like the build agent doesn't have enough privileges to register the assembly. How can I check it?
If anyone can think of other reasons or mayve even a solution I'd be happy to know about it.

Thanks.

1 comment
Comment actions Permalink

Could you please try changing build agent service accout to some real account. There are many issues connected with it.

You may try 'View thread dump' action on the running build page to see what is going on with a build.

Thanks!

0

Please sign in to leave a comment.