TeamCity integration with perforce client in Mac

HI All,

I am trying to run Continuous integration in Mac. When I try to configure perforce client, there is a field asking for "Path to P4 executable" . In case of Mac we have a unix executable as "/Applications/p4v.app/Contents/MacOS/p4v" . When I specify this and try to test the connection, then i get an error "P4V: unrecognized option '-Cutf8". utf8 is the encoding that i have specified. Whichever i specify in charset field gets appended to p4v.real -C and i get an error.

It would be of great help if someone knows the solution for this.

Thanks,
Saravanaprakash

3 comments
Comment actions Permalink

Hello,

  On your mac you should use not p4v visual client, but p4 command line executable. This command line client is a
  separate download from perforce.com site. Place it to a directory like /usr/local/bin and add executable permissions
  via "chmod +x p4" command. Then, use /usr/local/bin/p4 as path to perforce client in TeamCity.

  Kind regards,
  KIR

0
Comment actions Permalink

HI Kiril,

The steps you have mentioned were helpful. I have perforce visual client also installed in my computer. I have created a workspace and checked out contents from the server. I am giving the same workpace info in the client field of configuration setting. Now i get a Connection failed(client unknown) error.

Any pointers on to this?

Thanks,
Saravanaprakash

0
Comment actions Permalink

Hello,

   Please make sure you specify the correct client name in the perforce VCS settings.
   Or you can avoid using named client and specify client mapping directly in TeamCity UI.

   Please also take a look at http://www.jetbrains.net/confluence/display/TCD4/Perforce

   Regards,
   KIR

0

Please sign in to leave a comment.