Subversion Labeling Error: Labeling process failed: No labeling rules found for checkout rules

I am hoping someone can help me. Here is my setup:

TeamCity 3.1

My SVN repo looks like this:
http://subversionMachine/svn/project/trunk
http://subversionMachine/svn/project/branches/1.0
http://subversionMachine/svn/project/branches/1.1
http://subversionMachine/svn/project/tags

My VCS root is defines as the following in TC:

http://subversionMachine/svn/project

My checkout rules are the following:

+:branches/1.1


My Labeling rules are the following:

branches/1.1=>tags

When I try to tag the build from the changes "Label this build source" I get the following:

Failed: Failed to set label 'test': No labeling rules found for checkout rules branches/1.1=>branches/1.1

with the following stacktrace:


jetbrains.buildServer.vcs.VcsException: No labeling rules found for checkout rules branches/1.1=>branches/1.1

    at jetbrains.buildServer.buildTriggers.vcs.svn.SvnSupport.label(SvnSupport.java:36)
    at jetbrains.buildServer.vcs.impl.VcsLabeler.setLabel(VcsLabeler.java:40)
    at jetbrains.buildServer.vcs.impl.VcsLabeler.setLabel(VcsLabeler.java:52)
    at jetbrains.buildServer.serverSide.impl.FinishedBuildImpl.setLabel(FinishedBuildImpl.java:16)


I have gotten it to work in the past but it seams that everytime we update the TC project config to checkout a new branch it runs into this problem. So when the config was branches/1.0 the labeling worked. now that the config is branches 1.1 it does not.

I have tried changing my labeling rules to the following with No success:
+:branches/1.1=>tags
./branches/1.1=>tags


I have looked at some other threads but they were referencing the roots wrong and said they fixed it by using the same config that I have above.
Any help?

4 comments
Comment actions Permalink

Hello Edward,

   Sorry for delay with the answer.
   I've tried to reproduce your problem, but failed. Your configuration seems to work for me.

   Could you please try to change your checkout rules from +:branches/1.1 to +:branches/1.1=>.
   This may require some changes in your build script paths as well, but I suppose it may help with
   solving the problem.

   Please also make sure that your labeling rules have been saved successfully.

   I can prepare a patch with additional debug for your problem, but it will only work with
   TeamCity 4.0. I'd strongly suggest you to to give 4.0 a try, there were no noticeable changes
   in labeling code itself, but given that you experience the problem after changing build configuration
   settings I suspect there might be some bugs in configuration code.

   Kind regards,
   KIR

0
Comment actions Permalink

Yeah, I thought I would wait for any major bugs to shake out before upgrading. I created a test project just to test the labeling.

I created 2 projects: trunk and branch with the followng checkout rules:

+:trunk
+:branches/test1

and this is the labeling rules

trunk=>tags
branches/test1=>tags

THe SVN URL is the following:
https://machine1/svn/testrepo



The labeling works correctly. I thought it may be due to the fact that the configuration was copied but I made of copy of the build configuration and the labeling works as well.I does not make sense. Let me try your sugestion and see if that works.

0
Comment actions Permalink

I was able to get the labeling working by changing the checkout rules to :

+:trunk=>trunk
+:branches/1.1=>branches/1.1

However the labeling only works for future build. Trying to label previoues builds will not work with the same type of error.

0
Comment actions Permalink

Hello Edward,

  In fact, +:trunk=>trunk is exactly the same as +:trunk from the syntax point of view. I bet that if you change your settings back to +:trunk,
  the labeling will still work. Probably there was some trouble while copying build configuration .

  Regarding labeling of the previous builds - this probably won't work because the labeling uses checkout rules for the moment when the build was created.

  Kind regards,
  KIR

0

Please sign in to leave a comment.