Does teamcity support Subversive for Eclipse?

We use the Subversive plugin (instead of Subclipse) for our SVN needs in Eclipse. Does teamcity support subversive, and if not are there plans to do so? I'd really like to try out TC3!

Thanks,
Gilthalas

4 comments

Josh,

TeamCity do not support Subversive at this time.

Please vote for/watch the issue in our tracker: http://www.jetbrains.net/jira/browse/TW-4236

Without TeamCity Eclipse plugin, personal builds feature will not be available within Eclipse, but you can still use web UI and other advanced features of TeamCtiy.

--
Best regards,

Yegor Yarko
Project Manager
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

I noticed the tracker item you referenced has been dormant (no activity since it was opened!) - has there been any decision to push this forward?  Subversive, being an official Eclipse project, would be great to have full support for in TC. 

Thanks,
Josh

0

Seems like this issue is already fixed: http://jetbrains.net/tracker/issue/TW-4236
We've moved to other tracker and your link is obsolete. I wonder however why you was not redirected to the new tracker...

In brief TeamCity Eclipse plugin now integrates with Subversion with help of SVNKit library, so no other plugins are required.

0

Great!  I may have to try this out!  Thanks so much for the reply!

Josh

0

Please sign in to leave a comment.