Change Checkout Directory

Hi,
Due to the increase in the size of our codebase/VCS root, I am trying to move the checkout directory to another drive (Y:/BuildSource). In the buildAgent.Properties file and BuildAgent.dist.properties I've modified the workDir and tempDir to the appropriate paths as well as set the checkout paths in each build configuration but during the GET of sources, it still performs the GET to the default directory and not the directory specified. Any ideas on how to correctly change this?

7 comments
Comment actions Permalink

Hi,

  Are you sure you restarted the build agent after the change? Could you attach buildAgent/logs/teamcity-agent.log file?
 
  Regards,
 
  KIR

0
Comment actions Permalink

Yes, I've restarted the agent service multiple times and even rebooted the machine. It seems like it is addressing the correct directory but does not want to move the root of the checkout directory to this new location.



Attachment(s):
teamcity-agent2.log
build.log
0
Comment actions Permalink

According to your build log you do not have enough free space under <teamcity server>/temp folder to perform checkout from TFS.
Could you please check you have enough (more that checkout files size) space there.

Does Y:/ is network mapped path? If so, could you please make sure this mapping is registered under build agent service.
Frankly speaking, Microsoft does not recommend using mapped drives from services.

Thanks!

0
Comment actions Permalink

One more note.

TeamCity uses server to checkout files from TFS and only that files are sent to build agent machine. Thus changing build agent's working directory will not change the initial folder where TFS checkout is performed.

There is a patch for TeamCity 4.0.1 to support TFS on agent feature. Could you please try it as described at

http://www.jetbrains.net/tracker/issue/TW-6471

Thanks!

0
Comment actions Permalink

Hi Eugene,
thank you for your responses. The Y drive is an iSCSI drive that is used as a local drive. The issue I was facing is that I was running out of space on my C: drive and wanted to offload the checkouts/GETs to another drive. I've recently installed the latest version of TeamCity so perhaps a better question would be how do I specify the folder where the initial TFS checkout is performed? BTW the default agent and Teamcity Installation are on the same local machine. Ideally I'd like to have all of the checkouts/GETS to the Y: drive.

0
Comment actions Permalink

I've created an issue in our tracker for you problem at
http://www.jetbrains.net/tracker/issue/TW-6856
Please watch/vote for it.

As workaround could you please try providing CATALINA_TMPDIR environment variable
with path to the other drive.

Thanks!

0
Comment actions Permalink

Setting the CATALINA_TMPDIR environment variable did not seem to do anything. I'm going to go ahead and reinstall Teamcity on the Y drive. I am still interested in seeing a fix for this though. Thanks.

0

Please sign in to leave a comment.