Unzipping dependent artifacts isn't working

I'm trying to utilize the autmatic unzipping of zip artifacts inside '5.Dependencies' for a specific build.  I'm currently on build 4.0.2.  I'm using: myfile.zip!**  i'm getting the following error:

'Failed to download artifact dependency...' 

I've this issue before in another posting, but didn't see the resolve.  It just doesn't work or the instructions are incorrect.  I've been here: http://www.jetbrains.net/confluence/display/TCD4/5.Dependencies

But still getting failures.  I don't want to have to put an unzipping step inside my builds, especially since this is a published functionality.  It's an excellent feature.

Thanks for your time.

Dave

7 comments
Comment actions Permalink

Hello,

Can you attach teamcity-agent.log from agent's logs directory to help us investigate the problem?

0
Comment actions Permalink

Here are the logs.  I'm using this artifact dep:  CFCSYS.zip!**

Thanks.



Attachment(s):
Buildlog.txt
teamcity-agent.log
0
Comment actions Permalink

Are you sure that archive is not empty?

0
Comment actions Permalink

Yes.  Since this issue, I've added my own code to my build infrastructure unzip the same file.

0
Comment actions Permalink

I've checked this pattern just now and it works. Can you upload your archive to us (to ftp://ftp.intellij.net/.uploads)? In rare cases Java zip implementation is incompatible with others

0
Comment actions Permalink

I believe it made it.  Not sure.  But since you mentioned the condition of the zip file, I did run into a issue similar in my world.  The files in the zip file has a preceeding 'slash' which made the zip work in some places and not in others.  I'm gonna rebuild the zip file and test again.  I'll let you know my results and let me know if the ZIP file made it.

Thanks again for your time.

Dave

0
Comment actions Permalink

The slash at the begining of each file in the zip was it.  Now it works.

Thank you very much for your time.

Dave

0

Please sign in to leave a comment.