(Updated) TeamCity not finding NAnt

Please register a build agent or tweak build configuration requirements.

I'm using NAnt as the runner. What am I missing?

3 comments
Comment actions Permalink

I added the env.NAntHome property and pointed it to a relative path from the checkout: nant/NAnt.exe

I still get :
The following paths does not contain NAnt: E:\TeamCity\buildAgent\work\cc0d10face99ec2f\nant\NAnt.exe
E:\TeamCity\buildAgent\work\cc0d10face99ec2f\nant\NAnt.exe does not exists. Check NAntHome run parameter

I looked in that path on the agent and the files do exist. Is this a bug?

0
Comment actions Permalink

Anyone have an answer for this?

0
Comment actions Permalink

Answering my own question: Rather than setting a server environment variable for NAnt Home, I'm using "system.teamcity.checkoutDir%\nant"

0

Please sign in to leave a comment.