teamcity remove utf BOM signature when it checkout code from perforce

I have successful config teamcity v4.0 (Build 8080), with perforce as VCS provider. Orignly it works ok, but today I find a problem, I have checked in some resource that has different encoding, like UTF8,  UNICODE, all those resource file has a signature at the begining of the file. However, when teamcity checkout the code from perforce, the signature was removed. I wonder if it is issue caused by teamcity.
BTW, my perforce version is "Perforce Visual Client/NTX86/2008.1/164135".

3 comments
Comment actions Permalink

Hello,

  I suppose this could be a bug in TeamCity.

  But before filing it, please make sure that command-line client (p4), which is used by TeamCity, checkouts the file correctly.'

  If this is TeamCity's bug, please file it to http://jetbrains.net/tracker (please include as much details as possible about your p4 workspace settings and the example of the problematic file).

  Sorry for inconvenience,

  KIR

0
Comment actions Permalink

Kirill,

Thanks a lot, according to your response, I have check out the same file use p4v (perforce visual client), p4 (perforce command line), and teamcity. p4v and p4 get the same result. but the teamcity seems to have changed the encoding from UTF16 to UTF8 without BOM signature. I have put the check out files in the attachment.
     item.name_cmd                 ---      checked out by p4
     item.name_p4v                   ---      checked out by p4v
     item.name_teamcity           ---      checked out by teamcity
What's your idea? Thanks~



Attachment(s):
attachment.zip
0
Comment actions Permalink

Hello Vincent,

   Looks like this is a bug, I've filed it as http://jetbrains.net/tracker/issue/TW-7381 .

   We use Perforces API which doesn't return the file in correct encoding - I hope this will be fixed.

   Thanks for the report,
   KIR

0

Please sign in to leave a comment.