Java Version of Agent - how to (set &) use it ??

Hello,

I've got two projects:

  1. one requires Java 1.6
  2. second requires Java 1.5


and I have two agents that runs on each type of Java version.

How can I determine version of Build Agent's Java from TeamCity web interface?
Particularly I want to specify in my Build configuration->Agent requirements  (system/agent requirements)
something like that:  java.version "not less than" 1.6
So TeamCity will automaticaly use/choose proper BuildAgent for that build, but I dont know how to do it?
Can anyone help me?

3 comments
Comment actions Permalink

Hello Pawel,

  Please take a look at our docs at http://www.jetbrains.net/confluence/display/TCD4/Agent+Requirements
  and related pages.

  Hope this helps,
  KIR

0
Comment actions Permalink

Yes  of course but I didn't managed to make it work for me ;-(

0
Comment actions Permalink

Hello,

  I suppose you don't need any requirements for the project which requires Java 1.5. I suppose there is no problem if it will be built with 1.6, correct?

  For a buildAgent, which has java 1.6 installed, add the following line to buildAgent.properties:
  system.java16=true
  For the project, which requires 1.6, add a requirement "exists" for variable "java16".

  After that, your 1.6 project will be run only on agents which have system.java16 variable in config file.
  Hope this helps,
  KIR

0

Please sign in to leave a comment.