Updating Subversion client

Hi,

Is there a way to update the Subvesion client TeamCity uses?
I use TeamCity 4, I've upated my VisualSVN server to 1.7 (Subversion 1.6) and it doesn't seem to work with it.

Thanks.

5 comments
Comment actions Permalink

Hi,

I'm fairly new to TeamCity, however I've been using VisualSVN Server 1.7 (with the repo formats updated to SVN 1.6) and TeamCity 4.0 with no compatibility issues so far. What's the problem you're getting?

Rob

0
Comment actions Permalink

actually I even didn't update my repositories format to 1.6 (unless the VisualSVN msi does it automaticly).
I get this error:
Path XXXXXXXXXX is not canonicalized; there is a problem with the client.  [400, #0]
When I reverted to 1.6.4(subversion 1.5.6) it stopped happening.

0
Comment actions Permalink

No the VisualSVN server installation doesn't automatically upgrade the repos and so you have to do this manually. If you want to try updating the repos then go to the VisualSVN Server manager, right click the ROOT repos folder, select 'All Tasks' from the context menu, then select 'Upgade Repositories Format' from the sub menu. This will show a window that lets you decide which repos to upgrade. It's sound like maybe the repo URL itself is unusual: Does it contain any special chars or spaces or any funnies?

Rob

0
Comment actions Permalink

Thanks for your help Rob.
The url is all standard characters, also other clients worked with it perfectly.

0
Comment actions Permalink

No probs. I guess that there must have been a change to the canonicalization rules between SVN 1.6 and whatever SVN client version that's built into TC 4.0. If you have a spare server then maybe try out the current TC 4.1 EAP build http://blogs.jetbrains.com/teamcity/2009/02/23/opening-an-eap-of-teamcity-41/ ?

Rob

0

Please sign in to leave a comment.