Failed to get path to ssapi.dll

Hello all. I am currently in the process of setting up TeamCity at our company, but I can't get it to work with VSS. Current configuration:

  • TeamCity 4.0.2 (8222)
  • One local/default build agent
  • Visual Source Safe 2005
  • SQL Server 2005


All on the same machine. I run TC as a Windows Service under a domain account with administrative privileges. I set up one project with one build configuration:

  • VCS Checkout mode: Automatically on the server
  • Checkout directory: <empty>
  • No labeling
  • Correct path to the srcsafe.ini file
  • Correct username/password
  • Checkout options: Perform full checkout on every build
  • No automatic triggers are configured


When I press the "Test Connection" button in the Edit VCS Root screen it says: Connection successful! However, when I start a build (manually, by pressing the Run button) the build fails with the following error:

Could not get project sources: for build #20
jetbrains.buildServer.vcs.VcsException: Getting sources for checkout rule '.=>.' failed with erorr: VSS execution error: Failed to get path to ssapi.dll


SourceSafe is installed correctly. I installed an older version of "vss-support.jar" and then it works! That is, I don't get the "Failed to get path to ssapi.dll" error, but that older version gives me other problems that are also mentioned in other threads (i.e. not all source files are retrieved from VSS). So, I would rather use the updated version of vss-support/TC-VSS-Native.exe, because this seems to be the only version that has the "Perform full checkout on every build" option.

So, what am I missing here? Why can't it find the path to ssapi.dll? I attached the VCS log..

Thanks in advance for any help,
Rogier



Attachment(s):
teamcity-vcs.log
2 comments
Comment actions Permalink

I also let TC-VSS-NATIVE-*.exe log to a file where it thinks that SSAPI.dll is located:

TC-VSS-NATIVE-1235548699371.exe a b ss_path

It then outputs three files including a file called "a", see attachment. This file contains the correct path to SSAPI.dll. So: where does this message "Failed to get path to ssapi.dll" come from?!

Best regards,
Rogier



Attachment(s):
a
0
Comment actions Permalink

I've posted a workaround to the comment on the related issue at
http://www.jetbrains.net/tracker/issue2/TW-7299

Thanks!

0

Please sign in to leave a comment.