issue with build - java.lang.OutOfMemoryError: Java heap space

Folks - I'm using TeamCity 4.0.2.  I recently started to get the following failure.  Looks like its related to SVN.  I think this started to happen right after I upgraded to the latest Visual SVN Server (1.7.1 - based on Subversion 1.6.1).  Any ideas on how to fix this up?

[13:05:13]: Checking for changes
[13:05:14]: Clearing temporary directory: C:\TeamCity\buildAgent\temp\buildTmp
[13:05:14]: Checkout directory: C:\TeamCity\buildAgent\work\444338c803981184
[13:05:14]: Updating project sources
[13:05:14]: Updating C:\TeamCity\buildAgent\work\444338c803981184 from svn
[13:05:14]: Will use fast SVN update
[13:05:31]: Unexpected error: Java heap space
[13:05:31]: java.lang.OutOfMemoryError: Java heap space
java.lang.OutOfMemoryError: Java heap space
at java.lang.AbstractStringBuilder.expandCapacity(AbstractStringBuilder.java:99)
at java.lang.AbstractStringBuilder.append(AbstractStringBuilder.java:393)
at java.lang.StringBuffer.append(StringBuffer.java:225)
at org.tmatesoft.svn.core.SVNErrorMessage.getFullMessage(SVNErrorMessage.java:256)
at org.tmatesoft.svn.core.SVNException.getMessage(SVNException.java:79)
at java.lang.Throwable.getLocalizedMessage(Throwable.java:267)
at jetbrains.buildServer.vcs.svn.SvnCheckoutOnAgentSupport.updateSources(SvnCheckoutOnAgentSupport.java:97)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.checkoutSources(GetProjectSources.java:278)
at jetbrains.buildServer.agent.impl.patch.GetProjectSources.execute(GetProjectSources.java:100)
at jetbrains.buildServer.agent.impl.runStages.GetSourcesStage.doBuildStage(GetSourcesStage.java:31)
at jetbrains.buildServer.agent.impl.BuildRunAction.doStages(BuildRunAction.java:115)
at jetbrains.buildServer.agent.impl.BuildRunAction.run(BuildRunAction.java:81)
at java.lang.Thread.run(Thread.java:595)

[13:05:31]: Build finished


4 comments
Comment actions Permalink

Can you provide heap dump? Since the OOM occurs in the agent itself, to obtain heap dump you should add -XX:+HeapDumpOnOutOfMemoryError argument to agent JVM (http://www.jetbrains.net/confluence/display/TCD4/TeamCity+Startup+Properties#TeamCityStartupProperties-AgentStartupProperties)


If OOME occurs again .hprof file should be create in the agent working directory (most likely this is a bin folder of the agent). Pleae upload this .hprof file to our ftp server: ftp://ftp.intellij.net/.uploads

0
Comment actions Permalink

Hi Pavel,

I just uploaded java_pid3556.hprof but I couldn't confirm whether it got there ok.  Can you check?
please note that i've restarted my build machine and I still get the same error.

thanking you,
Suraj

0
Comment actions Permalink

Hello,

  In Subversion 1.6 there was some changes related to canonical paths processing. To fix your case, please try replacing https://THEPARTY:8443 with https://theparty:8433.

  Hope this helps,
  KIR

0
Comment actions Permalink

worked!  note that the port is still 8443, but making everything lower-case worked.

0

Please sign in to leave a comment.