VCS checkout with SVN server that requires 1.5 or newer

How do I get Teamcity 4 to use a SVN client with version 1.5 or newer?

The changelog for the 4.1 EAP builds inferred it supported 1.5 - but it's still getting rejected by our server.  We were using 8222 build, and upgraded to 8909 and it still had the problem.

I've seen notes about replacing the svnkit files, but nothing recent.

The posts I saw say to replace the svnkit the files in

webapps\ROOT\WEB-INF\plugins\lib

But I didn't see any svnkit files there, but they were in

webapps\ROOT\WEB-INF\plugins\svn\server

I tried replacing those, restarted teamcity web server service, and still no change.  I also noted the svnkit files were in webapps\ROOT\WEB-INF\plugins\svn\agent  in the zip file.

So what files do I replace update the svnkit elements.

1 comment
Comment actions Permalink

Resolved - issue was actually that the SVN gods had updated the DNS records, and Windows was refusing to update it's DNS cache on it's own.  the 'connection refused' was literally because it was connecting to the wrong IP.  ipconfig /flushdns and we were back in business.

The svn plugins in teamcity do use 1.5 already

0

Please sign in to leave a comment.