Teamcity 4.5 Cannot Create Build Configuration or VCS Root

I have a number of projects setup in our TeamCity deployment, however I cannot setup a Build Configuration in any of them.  When "Create Build Configuration" is clicked for Project A on the Administation Home Page, I am taken to the "Administration > Project A Project > Create Build Configuration" Page.  I fill in name and leave the rest defaulted, and click VCS Settings.

Now, on the VCS Settings page, if I go back to "General Settings" the name field is empty, and if I click "Choose Build Runner" I get a popup that says "Build configuration name is empty".  I have tried it with the following

FireFox 3.0.10 on Linux
FireFox 3.0 on WinXP
IE7 on WinXP

All have the same results.

Also, if I cannot ever setup a VCS Root.  The "New VCS Root" page has a field for VCS Root Name and a combobox for Type of VCS, but no save button or any action to save my configuration.

The user I am logged in as has System Administrator Privileges.

Screenshots are attached.


Thanks,
m.



Attachment(s):
vcs_root_capture.png
build_config_capture2.png
build_config_capture1.png
12 comments
Comment actions Permalink

I can't reproduce this bug. Please try to remove content of the TeamCity/work directory and restart server.

0
Comment actions Permalink

stopped server
removed work/Catalina
restarted server
logged in as user with System Administrator privileges

same result.

Here are some extra notes ::
- All users in TeamCity are mapped from an LDAP store
- TeamCity war is deployed on Tomcat 6.0.18 with JDK 1.6.0_07

License is Enterprise License.

0
Comment actions Permalink

Are there any error messages or exceptions in the TeamCity/logs/teamcity-server.log? Could you please try to remove caches in your browser.

0
Comment actions Permalink

No exceptions and no error level messages are in the teamcity logs.  I have the logs from a fresh start of TeamCity through a login and this problem bundled and will email them if you need them.

Cache on all browsers has been cleared multiple times.  Note that this is happening from all our systems.  Same behavior regardless of which system I login from ...


m.

0
Comment actions Permalink

Could you please provide a minimum number of steps to reproduce this bug? Probably you can provide screenshots of the steps?

0
Comment actions Permalink

Here are videos showing the steps for each scenario

Build Config Issue :: http://www.incursiontech.com/teamcity/build_config_video.avi

VCS Root Issue :: http://www.incursiontech.com/teamcity/vcs_root_video.avi


m.

0
Comment actions Permalink

Thank you for video. Unfortunately I did not get closer, because all of my attempts to reproduce this bug failed. How did you install TeamCity server? You mentioned that war file was deployed to Tomcat, did you unpack it before? TeamCity will not work if war file is not unpacked.

0
Comment actions Permalink

The TeamCity war was deployed as follows ::

- stopped tomcat
- mkdir ${CATALINA_HOME}/webapps/teamcity
- cd ${CATALINA_HOME}/webapps/teamcity/
- jar xvf teamcity.war
- install Maxim's updated ldap-login.jar for TC4.5 LDAP DN issue (See thread http://www.jetbrains.net/devnet/thread/281298?tstart=0)
- start tomcat


m.

0
Comment actions Permalink

Pavel,

quick update ... Not sure what causes it, but I cleaned out the TC4.5 install we had done, unarchived the TeamCity-4.5.war into our existing Tomcat and had the same problem.  I then copied the ROOT directory out of the standalone TC4.5 bundle and put it into our Tomcat server, and voila.  I am no longer getting the popup and my VCS Roots configuration is now showing up as well.


m.

0
Comment actions Permalink

Can you provide your Tomcat configuration: server.xml file? If possible please attach all logs from the Tomcat logs directory for the case when bug is reproduced.

0
Comment actions Permalink

let me know if you need any other info ...



Attachment(s):
teamcity-logs.tar.gz
server.xml
0
Comment actions Permalink

Still no luck. All I can suggest is to avoid NioConnector, but I am not sure it can cause such problems.

0

Please sign in to leave a comment.