Remote Run doesn't pick up subclipse password

Hi,

I am using TC 4.5 Enterprise Edition. (We are in the process of evaluating it and buying it if it works out).

I trying out the Remote Run feature and for some reason, it keeps asking me the password for the subversion repository over and over again. I keep entering it and clicking "Save Password", but that doesn't seem to stick.

This is really annoying since we have multiple modules and it seems like it asks for the password at least once per module... Actually, sometimes it seems like it's asking for the password more than once per module... Maybe once per modified resource?

What am I missing here? Did I miss a configuration somewhere? When I try to commit through regular subclipse functions, everything works just fine and it doesn't ask me for the password.

What should I do to get the password to stay?

Thanks,
Yaakov.

6 comments
Comment actions Permalink

Do you use connection to SVN over SSH/SSL? What Subclipse team provider are you using?

Thanks in advance,
Konstantin

0
Comment actions Permalink

No ssh or SSL. Just straight http://xxx....

0
Comment actions Permalink

Oh, yes... I didn't answer the 2nd question... I am not 100% sure what you mean by "team provider". You mean what SVN interface am I using, JavaHL (JNI) or the SVNKit (Pure Java)? Well, I tried it with both. Same result.

Yaakov.

0
Comment actions Permalink

Could you please inspect TeamCity's Password Management preference page(Window\Preferences\TeamCity\Password Management) next to you enter password for SVN - is there any entries?

TIA,
Konstantin

0
Comment actions Permalink

Yes, there is an entry there. It IS a bit strange to me that the value for location looks like this: <http://svn.xxx.com:80>, while the URL for the actual repository of the root svn directory is http://svn.xxx.com/someProjectName. The username value looks fine though...

I am hoping this can be resolved though... Remote runs is one of the biggest reasons we were considering buying licenses for this.

Thanks for helping. I hope either you or someone else has something else to suggest to fix this problem.

Yaakov.

0
Comment actions Permalink

Try to reset your cached SVN credentials(just delete in TeamCity/Password Management preference page).
Let us know your SVN authorization type.

BR,
Konstantin

0

Please sign in to leave a comment.