Build fails in TC but not from command line

I have a VB6 build, using msbuild, when i run it from the command line, it works okay, but not when run from TeamCity (4.5.1)

I get..

error MSB4067: The element <asdf> beneath element <ItemGroup> is unrecognised.

I have tried changing element asdf, but get the same issue (with new element name!)

I have other item groups within the msbuild file, they cause no issue.

anyone have any ideas?

heres my msbuild file....


<Target Name="BuildGUI">
<Message Text="VBP File.. $(GUIProjectFile)" />
<CallTarget Targets="UpdateVersion" />
<MSBuild.ExtensionPack.VisualStudio.VB6 TaskAction="Build" Projects="@(ProjectToBuild)"/>

<ItemGroup>
<asdf Include="..\..\Releasables\Executables\GUI\*.Exe" />
</ItemGroup>

<Message Text="Items in group= @(asdf)" />
<Copy SourceFiles="@(asdf)" DestinationFolder="..\..\Releasables\Executables\GUI\Package\Support" />

</Target>



4 comments
Comment actions Permalink

think ive found the issue...

having an <ItemGroup> within a target is a net 3.5 concept, i think TC is using 2.0 msbuild.

So.. how does one configure for 3.5 msbuild??

0
Comment actions Permalink

found it!!

config settings allowd me to choose 3.5, i was looking in the config xml and the like...

well.. thanks.

0
Comment actions Permalink

Sorry for delay with answer, we somehow overlooked your message. Glad you've solved your problem.

0
Comment actions Permalink

no problem.

It helped me to write it down.. then i found a related post somewhere, and investigated some more..

0

Please sign in to leave a comment.