Can not connect to remote subversion repository while behind proxy server

Hi I'm attempting to try out TeamCity at work, but I'm not getting very far as I can't connect to our subversion repository.

The repository is on a different site and the site I am working from uses a proxy server and the URL we use starts with https

I usually access it using TortoiseSVN, with the proxy details set in its Settings -> Network section.

However for TeamCity I was told I'd have to set the values in subversions serevers file.

So I editted the [global] section and set the values for:

  http-proxy-host
  http-proxy-port
  http-proxy-username
  http-proxy-password

I'd originaly set these incorrectly (left the spaces at the front) and TortoiseSVN stopped working, fixed that and Tortoise is all happy again.

However when I try to set up a New VCS Root in TeamCity and hit the Test connection button I get a dialog button with the following message

  svn: OPTIONS request failed on 'repository_name'

Any ideas what I'm doing wrong / missing out?

Cheers, Argos


3 comments
Comment actions Permalink

Hello Jason,

  Could you please check if you have option "Use default config directory" enabled for your VCS root?
  If this is the case, please file a bug to our issue tracker at http://jetbrains.net/tracker and please provide debug information
  as described at http://url.ie/12kd

  Thanks!

  KIR

0
Comment actions Permalink

Hello,

  We also have an issue http://jetbrains.net/tracker/issue2/TW-5709 in our tracker, if you believe you have the same problem,
  please watch/vote for it.

  Thanks,
  KIR

0
Comment actions Permalink

Sorry but I'm back on the site where the repository lives (and also on another project!) so I can no longer try that.

I might end up back on the problem site in the next few months, if I do I'll give it another go and let you know how I get on.

Thanks for trying to help,

Argos

0

Please sign in to leave a comment.