Inspections Runner and Error Settings

I can't seem to get the inspections runner to respect the inspection error settings in idea. They are in the project ipr file that the team city build config is using as far as I can tell, and are configured both globablly for the ide and project. Specifically I am trying to disable ejb errors.

I don't have anyting entered in the Inspection profile path, if that is needed.

5 comments
Comment actions Permalink

Could really use some help here, anyone have any ideas?

0
Comment actions Permalink

I had this problem, i found it difficult to configure which inspections in IntelliJ should run in TC (with respect to installed plugins locally in IntelliJ).
Feel free to vote for http://jetbrains.net/tracker/issue2/TW-6029 which would somehow resolve your problem.

Gilles

0
Comment actions Permalink

Thanks for the info. I am just trying to get the default, bundled code inspections working. I think I must be missing something simple. Should there be anything in the inspection profile path if it's already pointing to the ipr you want to use for inspections?



0
Comment actions Permalink

IIRC i had to install the J2EE plugin in IntelliJ to specify that I didn't want any J2EE inspections, so the .ipr would have this inspection specified as being disabled. Otherwise that would be enabled by default when ran by TC not seeing it listed in the disabled ones.
And no i don't think you must have something in the inspection field.
Just make sure that in IntelliJ the profile is set as the default one for you at the project level (not IDE level).

Gilles

0
Comment actions Permalink

Got it working by copying the default inspections profile to a new name and setting that to default for the project.

I appreciate the help.

0

Please sign in to leave a comment.