Error scanning JetBrains.BuildServer.NAntLoggers.dll for extensions when running NAnt script

Hi,

I am new to TeamCity and I am having a problem getting it to run my NAnt script.  I get the error below:

NAnt 0.85 (Build 0.85.2478.0; release; 14/10/2006)
Copyright (C) 2001-2006 Gerry Shaw
http://nant.sourceforge.net


For more information regarding the cause of the build failure, run the build again in debug mode.

Try 'nant -help' for more information

BUILD FAILED

Failure scanning "C:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NAntLoggers.dll" for extensions.
    Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.


I verified that the file exists in the location it is looking for. I am able to use the Command Line build runner, but I need to pass in properties to my NAnt script which apparently cannot be done with a Command Line build runner.

This has completely halted my build automation upgrades I am doing so any help is greatly appreciated!

Thanks in advance!

3 comments
Comment actions Permalink

Forgot to mention I am using the latest TeamCity - v 4.5.5


0
Comment actions Permalink

I also tried the latest TeamCity version 5 (EAP) with the same result.

Can anyone help me - I can replicate this with every installation I try (I have installed and received the same error on 4 different machines)

Thanks in advance!

0
Comment actions Permalink

I found the solution and thoguht I would post it here incase someone else ran into this problem.

I had to upgrade to the latest version of NAnt - I was using 0.85 and when I upgraded to 0.86 beta 1, the script ran fine.

Odd - but it worked...

0

Please sign in to leave a comment.