How can I interact with a build to resolve a prompt it gives from the command line?

I am running a grails build using the command line runner: grails.bat test-app -xml

I recently uninstalled the class-diagram grails plugin and now when team-city runs, I receive the following prompt in the log that blocks the build:

[08:40:23]: Plugin [class-diagram-0.2] is installed, but was not found in the application's metadata, do you want to uninstall? (y, n)


I have tried so many things to try and resolved this:
  • deleted .grails directory from my user directory
  • ran build from the agent (I don't encounter the error when running this way)
  • re-installed the plugin (I still get the error)
  • re-installed the agent (I still get the error)
  • set vcs options to always clean before build


How can I get past this error?

1 comment
Comment actions Permalink

I was able to get around this error by adding --non-interactive to my command line.  Now it looks like this:

grails.bat test-app --non-interactive

0

Please sign in to leave a comment.