Part Cover Support in Team City 5 EAP

Hi There,

I have Partcover configured in my build like this ..

Path = C:\Program Files\Gubka Bob\PartCover .NET 2.3\PartCover.exe
Include Patterns : [*]*
REport XSLT: C:\Program Files\Gubka Bob\PartCover .NET 2.3\xslt\Report By Assembly.xslt=>coverage.html

Now it seems to run fine but when I look for the coverage report the coverage page says "This is an autogenerated index file (there was no index.html found in the generated report)." and links to coverage.html.  The URL of coverage.html looks like ..
"<server>/TeamCity-10455/repository/archive/coverage.zip/buildId/64/coverage.html" and gives me a 404 error when I attempt to follow it.

Any ideas what I'm doing wrong?

6 comments
Comment actions Permalink

Do you have coverage.zip artifact in the build? Please attach contents of generated index.html and the list of files in .zip
Thanks!

As workaround, please try to specify xslt transform for index.html file in partcover settings.

0
Comment actions Permalink

Hi Eugene,

I do have the coverage.zip atifact and also the .teamcity->.NET Coverage->results floder which has some content.  I've attached a screenshot of the artifacts for the build and the coverage.zip .



Attachment(s):
atifacts.png
coverage.zip
0
Comment actions Permalink

Cloud you please attach partcover settings screenshot with all editors expanded.

0
Comment actions Permalink

Could you please try writing coverage..html instead of coverage.html in the XSLT rules.

0
Comment actions Permalink

I've reproduced and fixed the original issue. Thanks!
The soussgested workaround to use 'coverage..html' will work for you till update.

0

Please sign in to leave a comment.