Does TC5 + NCover 1.5 generate the html report?

I'm using the VS2008 solution build runner to run my tests and produce code coverage stats. I've managed to get it running but when I click on the build results I only get the "Code Coverage Summary" and the artifacts tab only includes CoverageReport.xml. I've looked at the build log and there seems to be a problem with NCoverExplorer.Console.exe (I've highlighted the error in bold):

14:13:06]: [Generate HTML report] Started NCover Explorer: "C:\Program Files\NCover\NCoverExplorer\NCoverExplorer.Console.exe" C:\BuildAgent\temp\buildTmp\tmpA667.tmp /html:C:\BuildAgent\temp\buildTmp\NCover26310Report\index.html /report:1 "/project:BarrHibb.Common-Trunk :: Code Coverage" /sort:0 //or FullCoverageReport:Html:{teamcity.report.path}

[14:13:06]: [Generate HTML report] Output: -----------------------------------------

NCoverExplorer.Console 1.4.0.7

(c) 2006 Grant Drake

http://www.ncoverexplorer.org/

-----------------------------------------

-- Options:

Project Name: BarrHibb.Common-Trunk :: Code Coverage

Acceptance%:  95%

Sort:         Name

Filter:       None

Report Type:  ModuleSummary(1)

Html Report:  C:\BuildAgent\temp\buildTmp\NCover26310Report\index.html




The given path's format is not supported.

Exiting with return code: 2

[14:13:06]: [Generate HTML report] NCover Explorer exited with code: 2
[14:13:06]: [Generate HTML report] NCover Explorer returned non-zero exit code.


Any idea why the path format is causing problems?


Thanks
Akash
2 comments
Comment actions Permalink

I've got one step further forward. I'm using an older version of NCoverExplorer (1.4.0.7) and so need to change the arguments passed to it to /r:ModuleClassFunctionSummary.

However, once I do that I am in the same situation as this: http://www.jetbrains.net/devnet/message/5253559#5253559 i.e. I have the coverage.zip artifact but no Code Coverage tab.

0
Comment actions Permalink

Figured it out. The code coverage report tab need the base path to be coverage.zip and the start page to be index.html

0

Please sign in to leave a comment.