System property in CVS branch?

My build configuration has a lot of CVS modules (20+) that all have the same branch name.  What I'd like to do is specify a system property in each of the VCS configs like ${cvs.branch}.  Then I can just change the system property in one place.  I tried it but it did not seem to replace the property.  Turning on the debug log I can see that it is definitely not replacing the property.  
[2009-11-30 12:36:01,895]  DEBUG [ Cached pool 40] -      jetbrains.buildServer.VCS - root details: CVS Root (1) {cvs-branch-name=%cvs.branch%; cvs-quiet-period=3; cvs-root=:pserver:user@server:/usr/local/cvsroot; cvs-tag-mode=BRANCH; local-server-command=server; module-name=CVSModuleName; secure:cvs-password=*****; ssh-port=22; ssh-use-ppk=false; teamcity:vcsRootName=CVS Root (1); vcs=cvs; ; ver:2}

I've defined a system property for the build configuration as "cvs.branch".  So I've tried putting the following into the branch field on the VCS settings like this: ${cvs.branch}  and  ${system.cvs.branch}   and  %system.cvs.branch%    and %cvs.branch%    none of these work.

I think that this layout of CVS is probably crazy since all the projects are so intertwined they can't be released separately.  At some point we are going to convert to subversion, then move everything into a single project with a lot of sub folders.  Then there will only be one VCS root.  For now though, I need to figure out if it is possible.

Can the branch name be a variable or system property?

Thanks,
Jim

3 comments
Comment actions Permalink

At the moment you can't use references in VCS root settings, this will not work. Please watch/vote for this issue: http://youtrack.jetbrains.net/issue/TW-5428

0
Comment actions Permalink

Thanks for letting me know.  That issue now has the second most votes (at least on the query I'm running in YouTrack) of open issues in TeamCity.

http://youtrack.jetbrains.net/issues/TW?q=sort+by:+votes+state:+open

0
Comment actions Permalink

As a follow up to this, I was able to get my VCS converted to SVN, which is much nicer than CVS in my opinion.  Now I have a single VCS root, with checkout rules like Pavel suggested in the comments on the above bug:
+:branches/%branch.variable.name%/=>.
Now when someone runs the release build, they just enter the name of the branch in SVN and go.  It's great!

0

Please sign in to leave a comment.