Problem with NUnit runner when using MSBuild 4.0

NUnit fails to launch when using MSBuild 4.0 in the build configuration.  Note that this is not a .NET 4.0 targeting assembly.  This is merely a build of a .NET 3.5 assembly that uses MSBuild 4.0 to build.  So it is not necessary to have NUnit running under CLR 4.

[00:46:38]: [Project "DotNetOpenAuth.sln.teamcity.patch.tcprojx" (Build_TeamCity_generated_0d5dab5f106c4d55afd3b1b6143a2bff;NUnit_TeamCity_generated_0d5dab5f106c4d55afd3b1b6143a2bff target(s)):] c:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe "@@" C:\TeamCity\buildAgent\temp\buildTmp\tmp5C0A.tmp
[00:46:38]: [Project "DotNetOpenAuth.sln.teamcity.patch.tcprojx" (Build_TeamCity_generated_0d5dab5f106c4d55afd3b1b6143a2bff;NUnit_TeamCity_generated_0d5dab5f106c4d55afd3b1b6143a2bff target(s)):] C:\TeamCity\buildAgent\work\c5fdf57062f802c0\src\DotNetOpenAuth.sln.teamcity.patch.tcprojx(10, 5): c:\TeamCity\buildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe "@@" C:\TeamCity\buildAgent\temp\buildTmp\tmp5C0A.tmp exited with code -2146232576.

This is blocking a project upgrade.  Any help getting NUnit to run would be greatly appreciated.
3 comments
Comment actions Permalink

Current NUnit runner supports only .NET 4.0 beta 1. you will have to update assembly .config file in the build agent:

Copy <server>/update/plugins/dotNetPlugin.zip to some temp folder.
update all config files matching the wildcard JetBrains.TeamCity.PlatformProcessRunner.v4.0*.exe.config:
please set the following startup configuration:

    <startup>
        <supportedRuntime version="v4.0.20506"/>
        <supportedRuntime version="v4.0.21006"/>
        <supportedRuntime version="v4.0.30128"/>
    </startup>


pack patched plugin and replace the original .zip file on the server.
Wait while build agent(s) autoupgrade.
Try running the build again.
0
Comment actions Permalink

I've made the change.  It still fails with the same error.  Can you explain why we need to add these .NET 4.0 supporting changes when NUnit can still run on CLR 2 for my assembly?

0
Comment actions Permalink

Ah, I was updating the wrong location's .zip file.  Once I updated the right one, it worked.  Thanks!

0

Please sign in to leave a comment.