"No modified files found" with TeamCity Visual Studio plugin and SVN 1.6.6

I setup TeamCity for the first time yesterday with the latest version (5.0.1 build 10715), and everything seems to work fine except that I can't seem to get the Pre-Commit feature to work. I am running VisualSVN server version 2.0.8 that hosts SVN version 1.6.6. I am also using Visual Studio 2008 with the TeamCity plugin. I see from my AnkhSVN plugin that the file is clearly modified, but the TeamCity plugin always shows the message, "No modified files found. Save all changes and Refresh." I setup the SVN settings for the plugin as well, pointing to the VisualSVN version of svn.exe.  I tried everything I can think of. I'm hoping someone has the answer. Thanks.

16 comments
Comment actions Permalink

Adam, thanks for your feedback!
Did you try to refresh Local Changes tool window with "Recollect Local Changes" button?
Could you please attach your TeamCity add-in logs. You could find them in %Temp%\JetLogs directory.

0
Comment actions Permalink

Thanks for the quick reply. I have tried refresh many times. Attached is my latest log. LicenseManager.cs is the file that has changed.



Attachment(s):
JetBrainsLog.TeamCity.2010-01-19T09-08-43.devenv#2076.log.zip
0
Comment actions Permalink

Adam, did you try to explicitly specify Subversion working copy root directory in Subversion settings of TeamCity add-in?

0
Comment actions Permalink

Yes. No luck there either.

0
Comment actions Permalink

Adam, please try this:
- close Visual Studio
- replace JetBrains.TeamCity.SVN.dll file in directory where add-in was installed with attached file
- open Visual Studio
- load ploblematic solution
- refresh Local Changes several time
Attach your last log file once again.



Attachment(s):
JetBrains.TeamCity.SVN.dll.zip
0
Comment actions Permalink

Thanks again for all the help.  I saw this assembly contained a new option in the TeamCity options under the Advanced section.  I tried enabling that and trying again, but no luck with it either.  Here is the log...



Attachment(s):
JetBrainsLog.TeamCity.2010-01-20T10-00-27.devenv#3256.log.zip
0
Comment actions Permalink

New Subversion option irrelevant to our problem.
Adam, did you perform checkout of your problemmatic working copy with AnkhSvn?

0
Comment actions Permalink

No, the checkout was performed with TortoiseSVN 1.6.6 Build 17493 (32-bit).

0
Comment actions Permalink

TeamCity doesn't require the solution to be in SVN does it?  My solution is not part of my SVN working directory.  That would be pretty dumb if it does though.

0
Comment actions Permalink

TeamCity add-in tries to detect SVN workin copy near opened solution.

ALove wrote:

That would be pretty dumb if it does though.


Agree, created new issue for this in our tracker (http://youtrack.jetbrains.net/issue/TW-10794)
Fell free to watch\comment\vote it.

0
Comment actions Permalink

Although I agree it is an issue, the issue you have written suggests that your solution must exist in your working SVN path.  There is no reason the solution needs to be there.  With the solution in the path, TeamCity thinks it is one of the included files with the changes.  I think your issue needs re-phrased.

0
Comment actions Permalink

Adam, sorry for delay! Lets go back to our discussion.
You was right, saing that issue, opened by me (http://youtrack.jetbrains.net/issue/TW-10794) doesn't relate to your problem.
As I now understand you have a solution with several projects, one of them is located inside the Subversion working copy, the other not.
My issue is concerned the solution, which is generally not associated with the Subversion. I closed that issue by adding an appropriate error message.
To handle your problem, i need to know more about your solution's structure.
But first of all, please try to install attached Visual Studio add-in and collect your Local Changes in problemmatic solution one more time.

PS: Attached add-in is our private build, so do not forget to upgrade to 5.0.2 version, when it would be released!



Attachment(s):
TeamCitySetup.5.0.30.0.msi.zip
0
Comment actions Permalink

Still not right. I have a solution and a single project within it that is under subversion. The solution however, is not under SVN. With your change, I now get an error from the addin saying that my solution is not under SVN. Instead of fixing the bug, you now have made it inform the user that there is a bug. TeamCity should use the project location of each individual project for changes if the project is under SVN. It should only check for solution changes if the solution is also under SVN. The point being, the TeamCity plugin should not stop working if the solution is not under SVN.

0
Comment actions Permalink

Adam,

I'm not sure if you ever resolved your problem, but I stumbled on this thread when trying to fix the same problem in my development environment.

I am running both AnkhSVN and TortoiseSVN, and they were both showing that there were pending changes, but this was not reflected in the TeamCity Local Changes window.  The TeamCity options window indicated that it was looking for svn.exe, which was not installed in the Program Files directory for either of these applications.  Ultimately, I installed Slik SVN (http://www.sliksvn.com/), which included this exe, among others.  I'm pretty sure that the CollabNet Subversion Command-Line Client will resolve this issue as well (http://www.collab.net/downloads/subversion/).

I hope this helps you or others that have the same issue.

0
Comment actions Permalink

David, thank you for your participation!

The TeamCity options window indicated that it was looking for svn.exe, which was not installed in the Program Files directory for either of these applications.

Yes, we use svn.exe as Subversion client, but, if you let TeamCity to detect svn.exe using system Path environment (checkbox on Subversion options page) and svn.exe is not accessible on your workstation throught "Path" environment variable, you ll see "The system cannot find the file specified" error message when collecting Local Changes.

0
Comment actions Permalink

David,

Thanks for the info. I do have SlikSVN installed as well and this is what the TeamCity plugin is configured to use. This is not my problem however since moving the .sln (solution) file into my project folder, causes TeamCity to start seeing my changes. They need to fix this bug.

0

Please sign in to leave a comment.