Help! Configuring git cvs root with ssh


I'm trying to configure a cvs host to talk with assembla's private git repository, but i cant get the test connection to succeed.  I already tried every combination of key file placemant and connection options, but i keep getting either an auth fail exceptions or a cryptic "1" exception. Im using the git plugin with team city 4.5.1. Im a git and ssh noob, so its very possible im doing something basic wrong. Can anyone help me?



The necessary configuration depends much on the git server configuration and I do not have Assembla account to check this.
Can you describe how you connect to your git repository on your desktop (how you configured git access credentials)?

Also, can you pelase provide more details on "cryptic '1' exception"?

Please also note what git plugin version you use.


We changed our git repository from assembla to github today, and the connection is working now. The cryptic one exception was just that, an exception with "1" as its message, I think it was because of misplaced ssh key files, using the public key instead of the private one, but im not sure. I sry  to not be able to give more details about the errors . Thanks for the help.


I am currently trying to get the git plugin to work with assembla as well, to no avail.  I am able to do a git checkout on the server itself using msysgit, and am also able to manually ssh using a cygwin prompt.  Can anyone point me in the right direction for troubleshooting the cause? All I get now is a generic error:

The connection test failed: com.jcraft.jsch.JSchException: Auth fail

I see in the documentation for the plugin that there is the line "For SSH to work you should have correctly configured $HOME\.ssh-*", but I don't know what the variable $HOME references, and I have not seen it anywhere else in the assembla documentation.

Here is one of the configurations I set up, I also tried the "Default Private Key" settings.


Thanks in advance.


Found the issue - assembla really wants you to use "git" as the username. So when I put the clone URL as, but put a value in for the username in the settings below, it was overriding the username and causing assembla to decline.  leaving an empty username field (or using "git") worked fine.


Please sign in to leave a comment.