TeamCity 4.5.5 Idea Git plugin installed, Agent does not support Git

Environment:
TeamCity 4.5.5
OS: Red Hat Enterprise Linux Server release 5.4 (Tikanga)
Java: java version "1.6.0_17"

I have installed the Git plugin from: http://teamcity.jetbrains.com/viewLog.html?guest=1&tab=artifacts&buildTypeId=bt152&buildId=lastSuccessful

into the plugins directory under the .BuildSystem directory.

I have been able to successfully add a VCS Root from the TeamCity administration panel.  I have also verified that teamcity has been able to download the git repository to the folder .BuildSystem/system/caches/git.

The problem is that when I try and assign an agent to build the configuration, I have no Git enabled agents.  Instead the message I get is:

Missed VCS plugins on agent:
  • Git (JetBrains)


Under the "Incompatible Configurations" side of the Agent-Compatible Configurations Tab.

I have tried several things.  I have restarted the agent multiple times, each time with the same result.  When that did not work I manually copied (I know that the agent is supposed to automatically copy available plugins) the plugin above to the TeamCity/buildAgent/plugins directory.  After restarting the agent it reloaded all the plugins from the TeamCity server and went back to being Git unaware.  I have included a log of that agent attempting to start up and it downloading the plugins it had available.

There is a plugin on GitHub located at http://github.com/chrisortman/git-teamcity/tree/ .  The one on GitHub is the only one that I have seen a mention of it working with the agent from this post http://www.knowledgetree.com/blog/continuous-integration-with-teamcity-git

Any help would be appreciated.  For additional help I have included the log from the TeamCity server as well.

As a side note, I tried placing the git plugin in the plugins directory of the server thinking that may help.  No luck.







Attachment(s):
teamcity-server.log.zip
teamcity-agent.log.zip
1 comment
Comment actions Permalink

It seems you have "Automatically on agent" checkout mode selected (see build configuration VCS settings step). Our git plugin does not support checkout on agent. You should change checkout mode to checkout on server.

0

Please sign in to leave a comment.