Build not triggering on VCS check-in

I'm sure I'm doing something silly, but I'm pretty new to administering TC builds. I have my version control settings set to "VCS checkout mode: Automatically on server", "VCS labeling: disabled", "Trigger build by vcs check-in: ON", "Quite period: not specified", but I still have to manually trigger the build. Any suggestions what else I can look at?

8 comments
Comment actions Permalink

Do you have VCS trigger rules specified? Can you provide a screenshot of VCS trigger page? Also does TeamCity detect changes and show them in Pending changes list?

0
Comment actions Permalink

Attached. No, there are no checkout rules. When I run the build manually, it does detect the changes fine. I've tried both "Automatically on Agent" and "Automatically on Server" (it's the same machine).



Attachment(s):
Capture.PNG
0
Comment actions Permalink

How about your build trigger rule?

0
Comment actions Permalink

Please provide screenshot of your VCS trigger section.

0
Comment actions Permalink

Attached



Attachment(s):
Capture.PNG
0
Comment actions Permalink

See above, I just posted it in reply to another post

0
Comment actions Permalink

What version control do you use? You mentioned that changes do not appear until you trigger a build manually, what checking for changes interval is specified for your build VCS root?

0
Comment actions Permalink

Aha! You put your finger right on the problem. The interval was set to once a day for some reason. Very odd. I didn't even know that setting was there!

0

Please sign in to leave a comment.