MC1000 error - MSBuild

Hi. I'm trying to build a .Net Project with teamcity (4.5.5 (build 9103) -  WindowsServer2003 x64).

As Build runner I tried sln2008 and MSBuild.
This Project works just fine in VisualStudio2008 but by the building in teamcity it always raise the following exception:

# C:\BuildAgent\work\CheckOutDir\custdev\Mobile_DotNet\Centrica\src\dev\Chimera\MobileClientTestApp\TestDialog\TestDialogView.xaml(15, 14): error MC1000: Unknown build error, 'Method 'ShowStatusMessage' in type 'com.sapcd.mobileclient.dialog.WPF.Controls.WPFStatusBar' from assembly 'SAPCD.MobileClient.Dialog.WPF, Version=0.91.3692.24907, Culture=neutral, PublicKeyToken=null' does not have an implementation. Line 15 Position 14.'
# C:\BuildAgent\work\CheckOutDir\custdev\Mobile_DotNet\Centrica\src\dev\Chimera\MobileLaptopClient\DataBrowser\DataBrowserView.xaml(15, 10): error MC1000: Unknown build error, 'Method 'ShowStatusMessage' in type 'com.sapcd.mobileclient.dialog.WPF.Controls.WPFStatusBar' from assembly 'SAPCD.MobileClient.Dialog.WPF, Version=0.91.3692.24907, Culture=neutral, PublicKeyToken=null' does not have an implementation. Line 15 Position 10.'
# C:\BuildAgent\work\CheckOutDir\custdev\Mobile_DotNet\Centrica\src\dev\Chimera\MobileLaptopClient\Info\InfoView.xaml(24, 10): error MC3074: The tag 'WPFStatusBar' does not exist in XML namespace 'clr-namespace:com.sapcd.mobileclient.dialog.WPF.Controls;assembly=SAPCD.MobileClient.Dialog.WPF'. Line 24 Position 10.
# C:\BuildAgent\work\CheckOutDir\custdev\Mobile_DotNet\Centrica\src\dev\Chimera\MobileLaptopClient\Main\MobileLaptopMainDialogView.xaml(39, 14): error MC3074: The tag 'WPFStatusBar' does not exist in XML namespace 'clr-namespace:com.sapcd.mobileclient.dialog.WPF.Controls;assembly=SAPCD.MobileClient.Dialog.WPF'. Line 39 Position 14.
# C:\BuildAgent\work\CheckOutDir\custdev\Mobile_DotNet\Centrica\src\dev\Chimera\MobileLaptopClient\Settings\Connection\SettingsView.xaml(85, 10): error MC3074: The tag 'WPFStatusBar' does not exist in XML namespace 'clr-namespace:com.sapcd.mobileclient.dialog.WPF.Controls;assembly=SAPCD.MobileClient.Dialog.WPF'. Line 85 Position 10.

Has anyone any idea why this happens?

Thanks.

1 comment
Comment actions Permalink

Could you please check user account that is used to run build agent service.

Please check if the build run from msbuild.exe on the build agent machine under the same user account.

Do you have the same SDK's installed on the build agent machine?

0

Please sign in to leave a comment.