Command line runner: errors with cmd-script 'call' command

I've recieved this problem 2 times
I use command line runner in agent for launch build-script. But if I use 'call' command into this script for run another script, par exemple:

@echo on
call BuildClient.cmd

call Deploy.cmd

exit /B 0


Script "BuildClient.cmd" is last command to run, after I've recieved error and Process exit code: 1
If I run my script from command shell - no problem
I try launch agent with admin's rights, but no success.

The first time than I recieved this error, we re-install Windows with TeamCity. Some time all was ok.
Now we recieved this error again.

3 comments

Ohh, we use Teamcity ver. 5.0.2 (build 10784) runs on WinXP SP3

0

Vic,

Sorry for the delay in replying.

Can it happen that the behavior of the "call" is the same withinTeamCity and in the console but "call BuildClient.cmd" fails for some reason in TeamCity and does not fail in console?
You will probably get the same behavior in console if the script fails.

0

I do not have this problem while I ran cmd-script in console
But I must do a remark - I have this problem only for scripts which work long time, while I created smalls scripts - no problem. And there was one feature - Teamcity said that these was error, but script (ANT job) was continuing work ...

P.S. Now I've recreated CMD script to ANT scripts and all works fine

0

Please sign in to leave a comment.