Can I stop TeamCity overriding the NAnt verbosity level?

Hello,

We have a few builds which zip up ~ 1 million files prior to deployment. TeamCity/NAnt logs the name of every file that is getting zipped up and this creates huge logs.

Although verbosity is set to false by default in NAnt, TeamCity seems to over ride this to true for the 'All Messages' build log.
This creates huge logs that are very slow to open. Is there a way to get TeamCity to recognise the verbose flag so I can control the level of logging?

This would also be useful for times when I want to protect information from people who have permission to view the logs. There are times when I would like to call a target but be able to stop TeamCity from logging the details. E.g. Server names, urls, usernames etc.

I have tried to create a custom NAnt task to silence the output for a target. This works fine when I run NAnt directly from the command line, but TeamCity manages to get all the logging information.

Are there any workarounds or settings that I can change to get TeamCity to recognise the level of logging for a NAnt target?

1 comment

Hello,

Please vote for the issue at
http://youtrack.jetbrains.net/issue/TW-6189

Is that possible to set verbosity level for that task?

You may create custom task that delegates/inherited from original Zip task but minimizes logging.

Another approach is to start another nant process from original NAnt script. You need to start it as another process in order to skip TeamCity NAnt listener to be used.

Thanks!

0

Please sign in to leave a comment.