NCover and 5.1 RC

Hi!

I'm trying to get NCover, framework 4 and VS2010 play nicely on our TeamCity server.

I run the NUnit test like this from our MSBuild file:

<NUnitTeamCity Assemblies="$(TestDllsForNunit)" NUnitVersion="NUnit-2.5.3" Platform="x86"/>

The settings for the build runner are MSBuild, Microsoft .NET Framework 4.0, ToolsVersion 4.0, Platform x86, NCover 3.x, .NET Framework 4.0, Platform x86, %system.ncover.v3.x64.path%

This worked fine up until 5.0 with .NET 3.5 but now I get the following error in the build (the tests run fine, it's just the ncover coverage that seems to be problematic).

[00:43:35]: C:\TeamCity\buildAgent2\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe v4.0 x86 NUnit-2.5.3 Omvard20.Tests\bin\x86\Debug\Omvard20.Tests.dll;Omvard20.IntegrationTests\bin\x86\Debug\Omvard20.IntegrationTests.dll
[00:43:35]: [Project "Omvard20.msbuild.teamcity.patch.tcprojx" (DevBuild target(s)):] C:\TeamCity\buildAgent2\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher.exe v4.0 x86 NUnit-2.5.3 Omvard20.Tests\bin\x86\Debug\Omvard20.Tests.dll;Omvard20.IntegrationTests\bin\x86\Debug\Omvard20.IntegrationTests.dll
[00:43:39]: 2010-04-16 00:43:39,028 [4416] ERROR JetBrains.BuildServer.NAntLoggers.NUnitLauncher2 - Failed to apply ITestRunnerExtension of JetBrains.TeamCity.CoverageSupport.CoverageRunner There is an error in the XML document.
[00:43:39]: System.InvalidOperationException: There is an error in the XML document. ---> System.InvalidOperationException: <ncover3 xmlns=''> was not expected.
[00:43:39]: at Microsoft.Xml.Serialization.GeneratedAssembly.XmlSerializationReader1.Read28_ncover()
[00:43:39]: --- End of inner exception stack trace ---
[00:43:39]: at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
[00:43:39]: at JetBrains.TeamCity.NUnitCommon.XmlSerializerFactory.LoadXmlObject(Type t, XmlElement element) in c:\Agent\work\6223f0c8b1d45aaa\src\NUnitCommon\src\XmlSerializerFactory.cs:line 43
[00:43:39]: at JetBrains.TeamCity.CoverageSupport.CoverageType.Load(ICoveragePlugin plugin) in c:\Agent\work\6223f0c8b1d45aaa\src\CoverageSupport\src\CoverageType.cs:line 24
[00:43:39]: at JetBrains.TeamCity.CoverageSupport.CoverageArgumentPluginParser.Load(ITestRunArguments args) in c:\Agent\work\6223f0c8b1d45aaa\src\CoverageSupport\src\CoverageArgumentPluginParser.cs:line 25
[00:43:39]: at JetBrains.TeamCity.CoverageSupport.CoverageRunner.Extend(ITestRunner runner) in c:\Agent\work\6223f0c8b1d45aaa\src\CoverageSupport\src\CoverageRunner.cs:line 52

Anybody who knows what might be the problem?
1 comment

Thanks you for feedback. I created an issue in our tracker at
http://youtrack.jetbrains.net/issue/TW-11680
Please watch and vote for it.
Let's continue out discussion there.

0

Please sign in to leave a comment.