Upgrade from 5.0.1 to 5.1 is going wrong

Hi,

I've just upgraded my server to 5.1, and now I have this :

Error on step: Connecting to the database server...
Unexpected exception when trying to connect from TeamCityDataSource:
Cannot create JDBC driver of class '' for connect URL 'null'
SQL exception: Cannot create JDBC driver of class '' for connect URL 'null'

The server cannot start. I put mysql drivers in /lib/jdbc  as said in doc, but nothing works...

WHen I look in log, nothing more.. First thing, there's not even logs!

Cannot call setFile(): java.io.FileNotFoundException:
../logs/teamcity-server.log (No such file or directory)
Cannot call setFile(): java.io.FileNotFoundException:
../logs/teamcity-server.log (No such file or directory)
Cannot call setFile(): java.io.FileNotFoundException:
../logs/teamcity-server.log (No such file or directory)
   WARN -   jetbrains.buildServer.SERVER -
Enabling of prepared statements pooling is dangerous and should be
avoided (can cause memory leaks), please remove
poolPreparedStatements=true property from database.properties file
Cannot call setFile(): java.io.FileNotFoundException:
../logs/teamcity-server.log (No such file or directory)
  ERROR -   jetbrains.buildServer.SERVER -
Server startup exception:
jetbrains.buildServer.serverSide.db.UnexpectedDBException: Unexpected
exception when trying to connect from TeamCityDataSource: Cannot create
JDBC driver of class '' for connect URL 'null'
SQL exception: Cannot create JDBC driver of class '' for connect URL 'null'


Why does it not found ../logs/teamcity-server.log ?

Thanks for your help.

Gérald

2 comments

Hi,

  What was your upgrade procedure? Are you sure you put jdbc driver to the correct location?
  How do you start TeamCity, via service or from command line?
  Please provide more information describing layout of the server.

  Regards,
  KIR

0

Hi,

Le 23/04/2010 22:39, Kirill Maximov a ecrit :

   What was your upgrade procedure? Are you sure you put jdbc driver to the correct location?
   How do you start TeamCity, via service or from command line?
   Please provide more information describing layout of the server.


I've copied new version over old one... It seems it's not the good way :)

I've installed a fresh new version, then just copy the .BuildServer
folder, and copied what I needed from config files (mysql, server
port...) and now it works.

Gérald

0

Please sign in to leave a comment.