Upgraded from 5.01 --> 5.1 now builds are not working anymore

Hi

I upgraded our TC server from v5.01 to 5.1 over the week-end and all of our builds have now started to fail.  The problem seems to be related the new MSBuild runner.  I've changed nothing to our build scripts which worked fine in v5.01.  I only upgraded the server.

Some background about our build process:

  1. Using MSBuild 3.5 to target .NET 3.5 SP1 platform
  2. Main build is defined in Main\Pragma.OnKey5.proj msbuild file
  3. We setup TC to fire off targets in this build file using the TC MSBuild runner
  4. We also have the DB build defined in a Main\Sql\Pragma.OnKey5.DB.proj msbuild file
  5. The main build file calls into the DB build file to build the DB by invoking the BuildAllDB target defined in the DB.proj
  6. As part of the BuildAllDB target within the DB.proj build we useMicrosoft's MSBuild task to compile the Main\Sql\Pragma.Tools.DbConversion\Pragma.Tools.DbConversion.sln.
  7. TC fails as it tries to run the BuildAllDB target from the Main\Sql\Pragma.Tools.DbConversion\Pragma.Tools.DbConversion.sln.proj that of course doesn't exist.

Can you please urgently assist us.  The CI server has basically come to a standstill because of the issue.

Find attached the log files from a build agent when the build fails and also the log files from the TC server itself.  Let me know if you require any additional information.

Thx


Attachment(s):
server logs.rar.zip
agent logs.rar.zip
4 comments

Thank you for feedback.

I noticed that build log lines started doubling.

Please try running the build with enabled .NET Coverage debug, set 'teamcity.agent.dotnet.debug' environment variable in the build configuration settings.
Attach new build logs and screenshot of the build configuration settings.

Do you start msbuild processes from your build script?

Thanks!

0

Hi Eugene

Find attached the latest agent log files after setting the environment variable.  Instead of trying to describe the build process, I include the project xml configuration file as well.  Have a look at the Main_Continuous_Tests configuration.  You'll find all the details of the build in there.



Attachment(s):
project-config.xml
agents log.rar.zip
0

I've noticed you use /p:key=value pattern instead of using Properties and Environment variables tab.
Could you please try moving all properties there.

Does your build work if start it on the build agent checkout directory under the same user account but from commandline?

Could you please attach build log downloaded from TeamCity server from link 'full log' where build has 'teamcity.agent.dotnet.debug'
environment variable set to 'true'.

Thanks!

0

Eugene

I've traced the issue down to a some rogue files being left over as part of a previous build.  Not sure how these files got created and why they were left behind after a failed build, but I've adopted our build script to be more strict about searching for specific build files and that seems to have solved the issue.

Thanks

0

Please sign in to leave a comment.