Unable to find build property system.Mono2.0

Hi all,

I've been trying to set up mono build using TeamCity 5.1.1. I get the following error while trying to run it:

[19:09:01]: Checking for changes
[19:09:03]: Clearing temporary directory: /opt/build-agent/temp/buildTmp
[19:09:03]: Checkout directory: /opt/build-agent/work/4f4ac537bbf6eb10
[19:09:03]: Updating sources: server side checkout... (1s)
[19:09:03]: [Updating sources: server side checkout...] Will perform clean checkout. Reason: Checkout directory is empty or doesn't exist
[19:09:03]: [Updating sources: server side checkout...] Building clean patch for VCS root: xxx - xxx
[19:09:04]: [Updating sources: server side checkout...] Transferring cached clean patch for VCS root: xxx - xxx
[19:09:04]: [Updating sources: server side checkout...] Repository sources transferred: 149.65Kb total
[19:09:05]: [Updating sources: server side checkout...] Removing /opt/build-agent/work/4f4ac537bbf6eb10
[19:09:05]: [Updating sources: server side checkout...] Updating /opt/build-agent/work/4f4ac537bbf6eb10
[19:09:05]: RunBuildException when running build stage CallRunnerStage: Unable to find build property system.Mono2.0 required to locate mono instance on the agent
[19:09:05]: Build finished

However the agent I'm running this on has that property defined (from "system properties" agent tab):


Mono   /usr/local/lib/pkgconfig/../../bin/mono
Mono1.0   /usr/local/lib/mono/1.0
Mono1.0_x86   /usr/local/lib/mono/1.0
Mono2.0   /usr/local/lib/mono/2.0
Mono2.0_x86   /usr/local/lib/mono/2.0
Mono3.5   /usr/local/lib/mono/3.5
Mono3.5_x86   /usr/local/lib/mono/3.5
MonoVersion   2.6.3
teamcity.agent.cpuBenchmark   96
teamcity.idea.home   /opt/build-agent/plugins/idea


Any suggestions on what might be going wrong?

Best regards,
Ilya
1 comment

Ilya,

This seems like a but that prevents the runner from starting. I filed it in our issue tracker as TW-12161 and hopfully it can be resolved soon.

Sorry for the inconvenience.

0

Please sign in to leave a comment.