Visual Studio 2010 Version required for build agent

Working on getting our TeamCity setup to build with the Visual Studio 2010 (sln) runner, and I have not been able to find which version of VS is required on the agent for the build.

Would  it be enough with an Express version, or is a Professional required.


/br

/Nikolaj

1 comment

Hello Nikolaj,

TeamCity uses MSBuild to run Visual Studio solution builds inside. You need to have .NET Framework SDK installed that includes MSBuild.


There is no needs to have VS installed on build agent except when your build script needs it. And even then there is no requirements on the studio version.


Kind regards,
Marina

0

Please sign in to leave a comment.